Check Vue Cli Version

Posted on  by admin

This quick tutorial will profoundly help you determine how to check the current vue js application version eloquently; we will share a couple of techniques with you to check the version of the vue js app.

Here is the small road map of this quick guide; we will install the vue cli and vue app, then ascertain the shortest techniques to comprehend the nuances of the current vue app version.

After going through this tutorial, you will be able to check the app version through command prompt, one-liner npm command and package.json. Vue CLI is a mandatory tool to create the vue app, so make sure to install it first.

Let’s begin installing the latest version of the Vue js app with the following command.


Don’t forget to enter into the project. Node.js Gatsby error – “digital envelope routines::unsupported …”. To remove above error for invoking the app, make sure to update the "scripts": [] array in package.json file.

In order to fix multi-word error, insert the given code in vue.config.js file.

After getting inside the app, let’s try our hands-on; the first pragmatic approach is to find out the current vue app version using a single command.

The above command displays the current app version on the cli interface.

Let’s jump on to another method, and we must say this method is very simple and drastically reduce the excruciating pain.

We will call the console.log() method and access the version property using the Vue object.

It will eloquently print the vue app version on the browser’s console.

You need to start the app development server; after executing the below command development server will start, and the app url will also appear on the command prompt screen.

Let me share the easy way to determine the current vue app version, and you need to look for the package.json file in your project root.

After that, open this file and look for the dependencies object; inside this object, you will see a vue prop with an app version number.

So, this was it; we hope you liked these methods to get the vue app version.

Warning regarding Previous Versions. The package name changed from vue-cli to @vue/cli. If you have the previous vue-cli (1.x or 2.x) package installed globally, you need to uninstall it first with npm uninstall vue-cli -g or yarn global remove vue-cli.

Node Version Requirement. Vue CLI 4.x requires Node.js version 8.9 or above (v10+ recommended).

You can manage multiple versions of Node on the same machine with n, nvm or nvm-windows. To install the new package, use one of the following commands. You need administrator privileges to execute these unless npm was installed on your system through a Node.js version manager (e.g.

After installation, you will have access to the vue binary in your command line.

You can verify that it is properly installed by simply running vue, which should present you with a help message listing all available commands.

You can check you have the right version with this command:.