Yarn Create Next App

Posted on  by admin

Modified11 months ago. I'm trying to start a nextjs project, and as of the documentation i'm running. But this command executes and returns an error. Can someone help me fix this? And please, explain why this error occurs so in the future i'll know how to deal with it. Noticed that the username contains a space, and that originates the error.Changing the windows username to a single thing without any spaces fixed the issue.

`yarn create next-app` fail with node 16.x.x #31307. yarn create next-app fail with node 16.x.x.

Replies

Running successfully? :P -- Sorry for this (required field).

  • Next.js does not depend on create-strapi-app and is fully compatible with Node.js 16 (and 17), what is happening here is that yarn is checking all globally installed deps during installation and that fails.
  • You'll want to remove create-strapi-app using yarn global remove create-strapi-app I guess. Going to convert this to discussions as it's not a bug in Next.js.
  • error [email protected]: The engine "node" is incompatible with this module. looks like that's an issue with create-strapi-app not create-next-app? There is new version of create-strapi-app. Current version is 3.6.8. Maybe a simple package upgrade will solve the issue.
  • Now I just checked, upgrade won't solve the issue, they don't keep up to date the package.json. Next.js does not depend on create-strapi-app and is fully compatible with Node.js 16 (and 17), what is happening here is that yarn is checking all globally installed deps during installation and that fails.
  • You'll want to remove create-strapi-app using yarn global remove create-strapi-app I guess. Going to convert this to discussions as it's not a bug in Next.js.

Not the answer you're looking for? Browse other questions tagged reactjsnext.js or ask your own question.

This is anomaly of yarn. Answer selected bytoviszsolt. Also fails on Node 14.15.4. I think is because of eslintrc. @ragnarok22 yes, it's eslint engine declaration problem, so you can write issue here: eslint/eslintrc.

  • How should developers create a new next.js app then in the meantime? Since this command won't work should we use the manual method? Just needed up to update to the latest version of node to avoid the eslint issue.
  • Sign up for freeto join this conversation on GitHub. Already have an account?
  • Sign in to comment.
  • Support for Examples: Create Next App can bootstrap your application using an example from the Next.js examples collection (e.g. npx create-next-app --example api-routes).
  • Tested: The package is part of the Next.js monorepo and tested using the same integration test suite as Next.js itself, ensuring it works as expected with every release.

Expected Behavior

For more information on what to do next, we recommend the following sections: